Jump to content

Photo

[DEAD] [2.53 Gamma 4] Sounds not playing ingame, and some set to 0 in


  • Please log in to reply
3 replies to this topic

#1 IcyMind

IcyMind

    .qst

  • Members
  • Real Name:Michael
  • Gender:Male
  • Location:Norway

Posted 23 February 2019 - 07:38 AM

This might be exclusive to my quests since they are based off the 210test.qst file from 2.10. My quests worked fine in 2.50.2, but putting them over to 2.53 brings up issues with certain sound effects. My quests were always saved in the 2.50.2 editor, but originated from the 2.10 quest file.

 

The sword slash sound is missing ingame. It is selectable and playable in the editor. It is also correctly set to have the 30th listed sound under the items related to it. The missing sword sound bug is present in both of my uploaded quests, plus the one I'm currently working on.

 

The enemy is hit sound also went missing at first, but I have not been able to recreate this one not playing. Going into the editor shows the sound as set to 0 in every enemy, but still works ingame.

 

I don't really want to make the quest file public, so I'm not sharing it here. I could send it on discord if you reach out to me. I have the same username/avatar.


Edited by IcyMind, 24 February 2019 - 08:09 PM.


#2 Avaro

Avaro

    Quest maker

  • Members
  • Real Name:Robin
  • Gender:Male
  • Location:Germany

Posted 23 February 2019 - 05:06 PM

Don't worry about enemy hit sounds set to 0 in editor, it's like that by default and will play the enemy hit sound regardless.

 

About the sword, yeah looks like a bug.



#3 klop422

klop422

    Evil Crazy Mastermind

  • Members
  • Real Name:Not George
  • Gender:Male
  • Location:Planet Earth

Posted 23 February 2019 - 05:32 PM

Don't worry about enemy hit sounds set to 0 in editor, it's like that by default and will play the enemy hit sound regardless.

Although, to be honest, I don't see why it should be this way, because it's kind of counterintuitive.

It's probably much too minor a thing to ask for in the feature request forum, but this is something that, in my opinion as a backseat designer, should probably be changed.



#4 ZoriaRPG

ZoriaRPG

    The Timelord

  • ZC Developers
  • Gender:Unspecified
  • Location:Prydon Academy

Posted 24 February 2019 - 07:09 AM

Come to think of it, I did fix the hurt sfx in 2.55. Perhaps I backported that fix and I didn't account for quests needing it loaded by default.

I'm unsure about the sword sfx.

 

Update: I tried a different sound effect on the sword, and it plays fine. Hmm, this does not occur in older 2.53 betas, not in Gamma 2. I wonder if the sound fixes for the cane of byrna did this.

 

Update 2: Fixed sword sfx.

 

Fixed Byrna Cleanup Routine killing SFX 30. This was caused by
`last_cane_of_byrna_item_id` never being able to be -1 because it was declared
as byte, instead of int.


  • IcyMind likes this


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users