Jump to content

Photo

Make game continue to play after not pressing anything


  • Please log in to reply
9 replies to this topic

#1 TheRock

TheRock

    Go glitches

  • Members
  • Gender:Male

Posted 18 September 2017 - 02:06 PM

So I want the game to continue to work even after you haven't pressed anything for like 3 minutes. I have tried to script it but it doesn't seem to work... Any ideas? Thanks.



#2 Cukeman

Cukeman

    "Tra la la, look for Sahasrahla. ... ... ..."

  • Members
  • Gender:Male
  • Location:Hyrule/USA

Posted 18 September 2017 - 02:55 PM

Do you mean you want to disable the screensaver?



#3 TheRock

TheRock

    Go glitches

  • Members
  • Gender:Male

Posted 18 September 2017 - 02:58 PM

Do you mean you want to disable the screensaver?

 

Yeah, I think that's what it is called.



#4 Saffith

Saffith

    IPv7 user

  • ZC Developers
  • Gender:Male

Posted 18 September 2017 - 05:18 PM

That's not something scripts can access. If you want to disable it, you can go to Misc. -> Screen Saver... and set it to run "Never." But there's no way to do that for everyone playing your quest.

#5 Jamian

Jamian

    ZC enthusiast

  • Members
  • Gender:Unspecified

Posted 18 September 2017 - 05:21 PM

It's a Zelda Classic option (Misc > Screen Saver).

 

It may be tricky to prevent ZC from starting the screen saver since you don't know what option the player picked (the screen saver can be set to be started after as little as 5 seconds of inactivity). 

 

This is untested, but you could try to manually input keystrokes via a script so ZC will think the player is still pushing keys. Use a key that is not actually used in your game (such as the Ex keys). I haven't tried, so I can't guarantee it will work.



#6 ZoriaRPG

ZoriaRPG

    ZC Contributor & Wiki Editor

  • Members
  • Gender:Unspecified
  • Location:Prydon Academy

Posted 18 September 2017 - 10:20 PM

Yeah, I think that's what it is called.


The screen saver should be disabled by default in all recent releases. What build are you using, that you see this?

#7 TheRock

TheRock

    Go glitches

  • Members
  • Gender:Male

Posted 19 September 2017 - 08:33 AM

The screen saver should be disabled by default in all recent releases. What build are you using, that you see this?

I was using 2.5.2 for Mac. 



#8 ZoriaRPG

ZoriaRPG

    ZC Contributor & Wiki Editor

  • Members
  • Gender:Unspecified
  • Location:Prydon Academy

Posted 21 September 2017 - 09:16 PM

I was using 2.5.2 for Mac.


That's strange. The screensaver should have been disabled in all builds > 2.50.1. Was it enabled by default for you?

We pretty much disabled the screensaver because it could cause crashes, or refuse to exit (i.e. wake up). AFAIAC, the screensaver may as well be pruned in some future build, if it has not been pruned from current.

#9 TheRock

TheRock

    Go glitches

  • Members
  • Gender:Male

Posted 21 September 2017 - 09:28 PM

That's strange. The screensaver should have been disabled in all builds > 2.50.1. Was it enabled by default for you?

We pretty much disabled the screensaver because it could cause crashes, or refuse to exit (i.e. wake up). AFAIAC, the screensaver may as well be pruned in some future build, if it has not been pruned from current.

Yep, is was on by default. I'm guessing it's only the Mac version.



#10 ZoriaRPG

ZoriaRPG

    ZC Contributor & Wiki Editor

  • Members
  • Gender:Unspecified
  • Location:Prydon Academy

Posted 21 September 2017 - 10:00 PM

Yep, is was on by default. I'm guessing it's only the Mac version.

 

I will certainly pay attention to this for 2.53. (We do not have a viable Mac build of that at present.)

 

I remember, even back in 2.50 betas, that the screensaver could cause ZC to lock up and become unresponsive. It was scrapped for a good reason. I do not understand why anyone needed it after DOS. 




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users