Jump to content

Photo

[NEW][CRASH][2.53]ZC crashes when out of focus


  • Please log in to reply
10 replies to this topic

#1 Russ

Russ

    Caelan, the Encouraging

  • Administrators
  • Gender:Male
  • Location:Washington

Posted 07 October 2018 - 09:09 PM

ZC will crash/hang if it is left out of focus for more than a few minutes. It ignores all inputs, and eventually Windows notes that the program is not responding. This is occurring with 2.53 Beta 19 on Windows 10. I don't know exactly when this issue began, but it was not present in 2.53 Beta 12. When Parsec (a program that shares audio/video and allows for remote input which I use for multiplayer in ZC) is running, this seems to happen more rapidly (within a minute, as opposed to 5 minutes or so). I don't know if it occurs with out screen capture programs.

Edit: This does not seem to occur if ZC is paused with escape before being brought out of focus.
  • ShadowTiger likes this

#2 ZoriaRPG

ZoriaRPG

    The Timelord

  • ZC Developers
  • Gender:Unspecified
  • Location:Prydon Academy

Posted 07 October 2018 - 10:00 PM

ZC will crash/hang if it is left out of focus for more than a few minutes. It ignores all inputs, and eventually Windows notes that the program is not responding. This is occurring with 2.53 Beta 19 on Windows 10. I don't know exactly when this issue began, but it was not present in 2.53 Beta 12. When Parsec (a program that shares audio/video and allows for remote input which I use for multiplayer in ZC) is running, this seems to happen more rapidly (within a minute, as opposed to 5 minutes or so). I don't know if it occurs with out screen capture programs.

Edit: This does not seem to occur if ZC is paused with escape before being brought out of focus.


What video driver do you have selected in zc.cfg? I'm guessing that you are back to DXGL?

I made GDI the default starting with beta 23, because of the limitless issues with Win10 and DX8.

#3 Russ

Russ

    Caelan, the Encouraging

  • Administrators
  • Gender:Male
  • Location:Washington

Posted 08 October 2018 - 01:16 AM

It's set to GDI (Slow) in ZLaunch.

#4 ZoriaRPG

ZoriaRPG

    The Timelord

  • ZC Developers
  • Gender:Unspecified
  • Location:Prydon Academy

Posted 08 October 2018 - 01:40 AM

It's set to GDI (Slow) in ZLaunch.

 

Interesting. I can confirm this, but I'm not sure what the culprit would be.

 

Would you be willing to go back and check Beta 12 again, and see if that is also doing it now, so that I can rule out that a Windows update might be the cause?

 

I'll check on my Win7 machine to see if this occurs. If it's only on Win10, then I may need to make ZC auto-pause if there is no input after 60 seconds--or some configurable number of frames

 

 

---

 

 

I just now finished checking the 2.53 beta builds from 23, back to 12. Every single one now does this. Please confirm, Russ, when you can, but I suspect that this was caused by a w10 update, and not by any change to ZC.



#5 Nightmare

Nightmare

    Original ZC Tester

  • Banned
  • Real Name:James
  • Gender:Unspecified
  • Location:Jackson, NJ

Posted 08 October 2018 - 06:18 AM

I'm reporting the same issue if you try to leave the window, and I have like not the greatest video stuff either. I don't even know where to look up the video stuff on mine.

-James

#6 Russ

Russ

    Caelan, the Encouraging

  • Administrators
  • Gender:Male
  • Location:Washington

Posted 08 October 2018 - 09:08 AM

Would you be willing to go back and check Beta 12 again, and see if that is also doing it now, so that I can rule out that a Windows update might be the cause?

I went back and checked, and this does not happen with Beta 12. I doubt Windows is responsible, as I have Windows Update disabled.

#7 ZoriaRPG

ZoriaRPG

    The Timelord

  • ZC Developers
  • Gender:Unspecified
  • Location:Prydon Academy

Posted 08 October 2018 - 11:06 AM

I went back and checked, and this does not happen with Beta 12. I doubt Windows is responsible, as I have Windows Update disabled.

 

:shrug:

 

It happens for me with Beta 12 on W10 1803 (KB4457128).

 

What is your W10 build? (You can check under 'Update history').

 

I guess I'll just add a timer that pauses ZC when it's idle. I may need to do the same for ZQuest, as I have reports of that hanging too, on W10, and all of this is W10 related.

 

I'll try DX drivers with DXGL next.



#8 Russ

Russ

    Caelan, the Encouraging

  • Administrators
  • Gender:Male
  • Location:Washington

Posted 08 October 2018 - 12:55 PM

What is your W10 build? (You can check under 'Update history').

Version 1703.

The auto-pause function sounds like the best work-around we can hope for.

#9 ZoriaRPG

ZoriaRPG

    The Timelord

  • ZC Developers
  • Gender:Unspecified
  • Location:Prydon Academy

Posted 03 March 2019 - 07:06 AM

Version 1703.

The auto-pause function sounds like the best work-around we can hope for.


Is this still an issue in Gamma 4 with the included zc.cfg anf zquest.cfg files?

The only time I have seen this happen, is if I suspend my system (hibernation, sleep) with ZC/ZQuest running, nd it was very rare. of the times it has happened, from some, I have been able to recover.

There are likely some config adjustments that help here. If we can narrow down what config options prevent this (if any), then I can make some presets in a future ZCK build.

Forcing a system pause is a bit tricker than it sounds, and not exactly ideal; but I'm willing to do it in a build at some point, if it is the only solution.

#10 Russ

Russ

    Caelan, the Encouraging

  • Administrators
  • Gender:Male
  • Location:Washington

Posted 07 September 2019 - 04:15 PM

For whatever reason, I wasn't notified of this post.

Yes, it's still problem in the final 2.53 release. Seems to be tied to the GDI driver specifically. Of course, if I switch back to DirectDraw, then I get the rainbow crash. At this point, it's starting to feel a bit like pick your poison.

#11 ZoriaRPG

ZoriaRPG

    The Timelord

  • ZC Developers
  • Gender:Unspecified
  • Location:Prydon Academy

Posted 08 September 2019 - 03:08 AM

For whatever reason, I wasn't notified of this post.

Yes, it's still problem in the final 2.53 release. Seems to be tied to the GDI driver specifically. Of course, if I switch back to DirectDraw, then I get the rainbow crash. At this point, it's starting to feel a bit like pick your poison.


I have it too, only with GDI. If you pause ZC first, it doesn't happen. Seems to be a bug in the allegro threads.

Have you tried DXGL with the DX video driver? We're reaching a point where getting off of DirectX is going to be mandatory, but we won't be able to do that until 2.60. It isn't as if we have a way to detect task-switch, or determine if ZC is not in focus, and this can literally happen the very instant that ZC with GDI drivers is brought out of focus, so a timer won't help..


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users