Jump to content

Photo

Current Version?


  • Please log in to reply
5 replies to this topic

#1 Obderhode

Obderhode

    There is great power in knowledge.

  • Members
  • Gender:Male

Posted 26 October 2019 - 07:58 AM

What version of ZC is the most stable / up-to-date? I have been using 2.5 and now that I'm back, I'm seeing lots of different versions of ZC and I am not sure which one I should use. It seems like 2.53 is the latest? But then I also see many threads with people mentioning 2.55 and that sounds like it'd be the latest.

 

I only need to change because in 2.50 now, for some reason, ZQuest will crash anytime I open the Item Menu, whether I do it through the menus or by pressing "I".

 

Thanks!



#2 Lüt

Lüt

    Germanize

  • Members
  • Real Name:Steve
  • Gender:Male
  • Location:Chicago

Posted 26 October 2019 - 08:02 AM

2.53.0 Release 2 is the "current stable" release.

2.53.1 is being worked on, and is in beta phase.

2.55 has many new additions, but is in alpha phase. However, it's built from 2.53, so basically everything that's stable in that version is also stable in 2.55, and it's generally only the new features that might have some flux or odd behavior to them, so don't be put off by the "alpha" if its features are appealing.
  • venrob likes this

#3 venrob

venrob

    Scripter / Dev

  • ZC Developers
  • Real Name:Rob
  • Gender:Male

Posted 26 October 2019 - 08:25 AM

2.53.0 Release 2 is the "current stable" release.

2.53.1 is being worked on, and is in beta phase.

2.55 has many new additions, but is in alpha phase. However, it's built from 2.53, so basically everything that's stable in that version is also stable in 2.55, and it's generally only the new features that might have some flux or odd behavior to them, so don't be put off by the "alpha" if its features are appealing.

This exactly.

The latest builds are always available at https://www.zeldacla....com/downloads/

2.50.2 (and lower) are OFFICIALLY UNSUPPORTED, so no one should really be using them anymore (aside from non-windows-users, as the new versions only have Windows builds thus far). This means you should update at MINIMUM to 2.53.0, though 2.53.1 is basically built right from the same code as 2.53.0 with a few new things WIP; so it should be just about as stable. 2.55 then is in alpha, but alpha does NOT mean 'unstable', it means 'new stuff is still being added'. We hope to move 2.55 to beta soon, at which point new stuff (aside from anything we put in the spec for beta) will NOT be added, and the majority of updates during beta will be bugfixes for the features. As Lut said, mostly anything that is stable in 2.53 is stable in 2.55; the only stuff that has a real chance to be unstable are new features.

 

All that said, it is ALWAYS recommeneded that WHENEVER you change ZC versions, always back up your .qsts for any quests you are developing.

For PLAYING quests, if you notice any oddities that are different between versions in the same .qst, please file a bug report in the proper subforum.


  • ShadowTiger likes this

#4 Obderhode

Obderhode

    There is great power in knowledge.

  • Members
  • Gender:Male

Posted 27 October 2019 - 05:36 AM

Thank you. :)



#5 Sans

Sans

    Hey kid wanna buy hot dogs ?

  • Members
  • Gender:Male
  • Location:Judgement Hall

Posted 27 October 2019 - 09:11 AM

Obderhode if you wish to try to make your quest in 2.55 make sure that you have a backup of your quest because if you save your quest in 2.55 without backup you'll no longer be able to work on it in previous versions. Seriously you really don't want to make the same mistake as i did before. It's not against 2.55 i say that by the way. Before i worked in 2.50.2 for many of my quest and now i works in 2.53 that is more stable then 2.50.2 (as i was told ).



#6 venrob

venrob

    Scripter / Dev

  • ZC Developers
  • Real Name:Rob
  • Gender:Male

Posted 27 October 2019 - 09:19 AM

Obderhode if you wish to try to make your quest in 2.55 make sure that you have a backup of your quest because if you save your quest in 2.55 without backup you'll no longer be able to work on it in previous versions. Seriously you really don't want to make the same mistake as i did before. It's not against 2.55 i say that by the way. Before i worked in 2.50.2 for many of my quest and now i works in 2.53 that is more stable then 2.50.2 (as i was told ).

All that said, it is ALWAYS recommeneded that WHENEVER you change ZC versions, always back up your .qsts for any quests you are developing.
For PLAYING quests, if you notice any oddities that are different between versions in the same .qst, please file a bug report in the proper subforum.

Yep, exactly as I said, and exactly as Zoria and I will always say whenever discussing upgrading version. ALWAYS make backups. Always. Always.


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users