Jump to content

Photo

MIDI changes to piano


  • Please log in to reply
3 replies to this topic

#1 Jared

Jared

    Lost at sea

  • Members
  • Real Name:Jared
  • Gender:Male
  • Location:Massachusetts

Posted 23 August 2019 - 08:08 PM

Any chance we could get this fixed, finally? :P I had to reinstall MIDIs through Coolsoft, which now makes my MIDIs turn into piano when I click out of ZC.



#2 Saffith

Saffith

    IPv7 user

  • ZC Developers
  • Gender:Male

Posted 23 August 2019 - 11:30 PM

In ag.cfg (or whatever it is now), set midi_patch_fix=1. It's not perfect, but it should keep the instruments correct.
  • Jared likes this

#3 Avaro

Avaro

    Quest maker

  • Members
  • Real Name:Robin
  • Gender:Male
  • Location:Germany

Posted 24 August 2019 - 10:27 AM

What version of ZC do you use? I thought 2.53 and newer fixed it. Or possibly this is a fault of Coolsoft. Either way, in 2.53 or newer, you need to refer to zc.cfg instead of ag.cfg.


Edited by Avataro, 24 August 2019 - 10:28 AM.


#4 Jared

Jared

    Lost at sea

  • Members
  • Real Name:Jared
  • Gender:Male
  • Location:Massachusetts

Posted 26 August 2019 - 04:06 PM

I'm actually using 2.53. Saffith, I tried that setting and it didn't do anything. :/


What version of ZC do you use? I thought 2.53 and newer fixed it. Or possibly this is a fault of Coolsoft. Either way, in 2.53 or newer, you need to refer to zc.cfg instead of ag.cfg.

I found the zc.cfq file and changed the setting as well, but it didn't fix anything.


Edited by Jared, 26 August 2019 - 04:07 PM.



1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users