Jump to content

Photo

Zelda Classic 2.50


  • Please log in to reply
238 replies to this topic

#226 Mero

Mero

    Touch Fluffy Tail

  • Banned
  • Real Name:Tamamo No Mae
  • Gender:Female
  • Location:Rainbow Factory

Posted 12 January 2014 - 05:16 PM

Are these scripts being loaded into the buffer? All scripts must be loaded into the buffer when you compile.


  • SkyLizardGirl likes this

#227 WhippyBoi

WhippyBoi

    You don't belong in this world

  • Members
  • Real Name:Lucas
  • Gender:Male

Posted 27 March 2014 - 05:00 PM

Now I can finally put the Roc's Feather inthe game! Woohoooooo!!!!!



#228 Naru

Naru

    Magus

  • Members
  • Gender:Unspecified

Posted 12 June 2015 - 12:53 PM

Hey there, where can I download 2.50? I can only find 2.50.1 and Eiyuu cannot be finished in that version.



#229 Avaro

Avaro

    Quest maker

  • Members
  • Real Name:Robin
  • Gender:Male
  • Location:Germany

Posted 12 June 2015 - 01:01 PM

Hey there, where can I download 2.50? I can only find 2.50.1 and Eiyuu cannot be finished in that version.

 

Well, for some reasons the quest creators who are aware of game breaking bugs in 2.50.1 don't investigate the issues with the developers I think. Anyways, go here: http://www.shardstorm.com

Build 1606 should be 2.50.


Edited by Avataro, 13 June 2015 - 08:21 AM.

  • Naru likes this

#230 Naru

Naru

    Magus

  • Members
  • Gender:Unspecified

Posted 13 June 2015 - 12:52 AM

Hmm, not sure, if I do anything wrong, but if i download the zip-folder for windows, build 1606, it is empty...

I will try with Build 1571, thank you for your help.

 

[edit] OK, found a warning in there, so I rather will avoid using it.


Edited by Naru, 13 June 2015 - 12:57 AM.


#231 Avaro

Avaro

    Quest maker

  • Members
  • Real Name:Robin
  • Gender:Male
  • Location:Germany

Posted 13 June 2015 - 08:31 AM

Hmm, not sure, if I do anything wrong, but if i download the zip-folder for windows, build 1606, it is empty...

I will try with Build 1571, thank you for your help.

 

[edit] OK, found a warning in there, so I rather will avoid using it.

 

Build 1571 is a release candidate for ZC 2.5. That's why the warning is there. It's not the final 2.5 version though, so I'm not sure if the quest will work right in that version. If you want I could zip together my ZC 2.5 and upload it to mediafire.



#232 Air Luigi

Air Luigi

    Tio guachi

  • Members
  • Gender:Male
  • Location:Spain

Posted 15 June 2015 - 05:48 PM

I also need a link with ZC 2.5.0 =(



#233 ZoriaRPG

ZoriaRPG

    The Timelord

  • ZC Developers
  • Gender:Unspecified
  • Location:Prydon Academy

Posted 17 June 2015 - 07:29 AM

2.50-Final Standard Package (Windows) Mirror
2.50-Final Scripters' Base Package (Windows) : Includes many important, non-standard, but often required, base headers.
 
2.50-Final (MacOS X Intel) Mirror.
2.50-RC5 (Linux) Mirror.

Apparently, I lack 2.50-Final (Linux) on my RAID arrays. :(

I may have 2.11b for MacOS X (PowerPC) or 2.10.x for PowerPC lingering somewhere too.

Edit: 2.11b (Build 919 for PowerPC) MacOS X. Mirror, don't expect it to play modern quests, but if you need your ZC fix on your iBook, or Powermac G5, this might do it for 2.10 quests; or it may just crash. :P

Edited by ZoriaRPG, 17 June 2015 - 07:58 AM.

  • ShadowTiger and Naru like this

#234 Air Luigi

Air Luigi

    Tio guachi

  • Members
  • Gender:Male
  • Location:Spain

Posted 17 June 2015 - 03:34 PM

Thank you ;)



#235 ZoriaRPG

ZoriaRPG

    The Timelord

  • ZC Developers
  • Gender:Unspecified
  • Location:Prydon Academy

Posted 17 June 2015 - 07:09 PM

Thank you ;)

 

You're quite welcome. The 2.50 Final files should not have been removed from the main ZC website, IMO.



#236 SUCCESSOR

SUCCESSOR

    Apprentice

  • Members
  • Real Name:TJ
  • Gender:Male

Posted 18 June 2015 - 02:52 AM

You're quite welcome. The 2.50 Final files should not have been removed from the main ZC website, IMO.

Well, they were removed before anyone made light of the bug that cause quest compatibility issues. Since that problem is now known and 2.50.2 is getting a little more work done (and thus getting released later than expected) I have put 2.50 files back up on ZC.com

 

I meant to do this a few days ago but... whoops.

 

http://zeldaclassic.com/downloads.php

 

lemme know if any of the links don't work. They all should nothing has really changed since before the 2.50.1 links were put up.


Edited by SUCCESSOR, 18 June 2015 - 03:01 AM.


#237 ZoriaRPG

ZoriaRPG

    The Timelord

  • ZC Developers
  • Gender:Unspecified
  • Location:Prydon Academy

Posted 18 June 2015 - 06:11 AM

Well, they were removed before anyone made light of the bug that cause quest compatibility issues. Since that problem is now known and 2.50.2 is getting a little more work done (and thus getting released later than expected) I have put 2.50 files back up on ZC.com

 

I meant to do this a few days ago but... whoops.

 

http://zeldaclassic.com/downloads.php

 

lemme know if any of the links don't work. They all should nothing has really changed since before the 2.50.1 links were put up.

 

Suggestion: Might it be a good idea, to add an 'old versions' link, and just host all the old versions of ZC/ZQ/related software, in an archive? Think: oldversion.com.

 

I know there are a whopping great number of 'build' versions, but at least the main versions, and the versions that cut certain compatibilities, should probably always be available.

 

I also suggest that when 2.50.2 is out, you (or any other SysOp) move 2.50.0 and 2.50.1 down on the page, to where you have the other old versions (2.10, and such). There are minor version differences between all three, that could cause things to break. This is further compounded by old, pre 2.50-Final, 2.5 quests...

 

Most games will run in 2.50.0 Final, but very few were designed around 2.50.1, and none thus far around 2.50.2, so keep that in mind for the future. I know that at least some 2.50-beta era games can break, even under 2.50-Final.

 

Then, there are the even more stubborn 2.10.1 and 2.11b games, so it's good to keep the core, benchmark releases available.

 

Zeldaclassic.com seems down at present: I suspect you're doing maintenance, or at least, I hope it's something simple along those lines. .

 

P.S. If you need a mirror for ZC versions, I'll put one (or two) up.


Edited by ZoriaRPG, 18 June 2015 - 06:16 AM.


#238 SUCCESSOR

SUCCESSOR

    Apprentice

  • Members
  • Real Name:TJ
  • Gender:Male

Posted 19 June 2015 - 06:25 PM

Verify zc.com is actually down or it's just for you. It hasn't been down for me and we aren't doing any maintenaince. Somethings AGN and ZC go down for a few minutes every now and then. Don't ask me why.

 

We could make every single version of ZC readily available, but I'd think that could also contribute to going back to "use this version for my quest". That sort of thing is bad for development. It is the job of quest developers to update and test in the latest version of ZC. If something doesn't work in the latest version it needs to be reported so we can sort out quest bugs and ZC bugs. The bug causing issues with 2.50.1 could have been taken care of a long time ago had it been reported ASAP. Unless it's decided otherwise 2.50.2 will likely replace all 2.5 links on the download page.


Edited by SUCCESSOR, 19 June 2015 - 06:50 PM.

  • ShadowTiger likes this

#239 ZoriaRPG

ZoriaRPG

    The Timelord

  • ZC Developers
  • Gender:Unspecified
  • Location:Prydon Academy

Posted 21 June 2015 - 10:10 AM

Verify zc.com is actually down or it's just for you. It hasn't been down for me and we aren't doing any maintenaince. Somethings AGN and ZC go down for a few minutes every now and then. Don't ask me why.

 

We could make every single version of ZC readily available, but I'd think that could also contribute to going back to "use this version for my quest". That sort of thing is bad for development. It is the job of quest developers to update and test in the latest version of ZC. If something doesn't work in the latest version it needs to be reported so we can sort out quest bugs and ZC bugs. The bug causing issues with 2.50.1 could have been taken care of a long time ago had it been reported ASAP. Unless it's decided otherwise 2.50.2 will likely replace all 2.5 links on the download page.

 

In that case, why are 2.10 versions there; but not 2.10.1, or 2.10.2?

 

People do take advantage of ZC bugs, and quirks during game development. While there might eventually be a quest rule for everything, perpetual retesting is  impractical, for every game that produced in the history of the programme. Even the databases here, contain files that it is impossible to use, or even open, without first processing them through extremely outdated ZQ versions.

 

Beyond that, the core developers cannot physically handle making every old project work with the latest releases. It's far more practical to make the old executables available for the two, or three games that need them, than it is to adapt the game engine, and the compiler, to both seal a bug, and allow an old quest that needs that bug to function, to work as intended.

 

Even Eiyuu breaks under 2.50.1, because of 'bugs' in 2.50.0, that many users treated as 'intended features'. ZC is one of those things, where the smallest change may cause something to crumble. That;s why I say, make them available as an archive. Unsupported, but available. Does it ultimately matter if a small percentage of quests require using an old version?

 

I know that a large percentage 'require' 2.10, and people still design for 2.10 to this day, which can cause problems loading new quests in the latest viewer; yet 2.10 is prominently featured on the main download page, despite being twelve years old; and despite there being minor updates to it, that are not featured.

 

If you don't  want them on Zeldaclassic.com, send me a ZIP (or GZIP, TAR, ZLIB, or RAR format) archive of the releases, or put that on a server somewhere, and I'll happily make a mirror available of everything, because it costs me nothing to do that. I could even put together some VM images to run 1.xx versions, for the people that need them on modern hardware.


Edited by ZoriaRPG, 21 June 2015 - 10:12 AM.

  • Naru likes this


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users