Jump to content


Zelda Classic Downloads, Information, and FAQ

  • This topic is locked This topic is locked
No replies to this topic

#1 Ebola Zaire

Ebola Zaire

    no fun. not ever.

  • Members
  • Real Name:Mitch
  • Gender:Male
  • Location:Alabama

Posted 25 March 2009 - 01:02 PM

~Zelda Classic Downloads, Information, Frequently Asked Questions, and Common Problems~

This is where the magic begins. There are two main programs that comprise the "Zelda Classic Experience." The first is the eponymous Zelda Classic. It's kind of like a movie player- alone, it doesn't do much, but when loaded with quest files (filetype .qst) you can play an almost endless selection of quality games. The second main program is ZQuest, which is what most people come here for. ZQuest acts as a mapmaker program- the questmaker can create quests to be played by others. To explain the relationship between the two programs: ZQuest creates .qst files with are then played using Zelda Classic.

~Windows Downloads~
Version 2.50 - The latest version of Zelda Classic. This version is packed with new features such as an enemy editor, item editor, scripting, and more. This also includes a better, larger interface with more features. This version is for Windows XP or later.
Version 2.10 - Introduces several new features over 1.92b183 but also has a reputation for lower stability.
Version 2.10.2 - Fixes some bugs found in 2.10, but introduces others. Quests made in this version are compatable with quests made in 2.10, and the two versions are largely interchangeable.
Version 1.92 b183 - A commonly used version with a reputation for sturdiness. The only beta version allowed in the database currently.
The 184 Player - A supplement to b183. Fixes some bugs in the Zelda Classic program, but does not contain ZQuest. Download the above version before this, and save both to the same folder.
Version 1.90 - Popularly known as the most stable version, but so old that it's virtually obsolete. Runs in DOS.

~Macintosh Download~
Version 2.50 - This is the only released version that supports Mac OSX.

~Linux Download~
Version 2.50 - This is the only released version that supports Linux.

~Choosing a Version~
If you are looking for both stability and more features, 2.50 is the version to download. Each older version has fewer features. 2.10 and 2.10.2 are relatively less stable than the other listed versions. Some ZQuest veterans still use 1.92b183 or older due to both stability and simplicity.

~Frequently Asked Questions~
This section is devoted to the questions most frequently asked about either of the Zelda Classic programs. Note that this section does not include questions about certain things in the editor- such topics are better suited for ZQuest Editor Help. However, you may still find it helpful to peruse the questions here- who knows, you may learn something.

Q: Help! I want to play, but I keep getting 1st.qst not found!
A. You need to press Escape, go into the Misc. menu and select Quest Dir. Then find the folder where all of your quests are. When you have, click OK and try playing again.
Q: Help! I want to play Happyman's Ebola Zaire's professional and brilliant quests, but I can't play custom quests.
A. First of all, I've never finished a quest. To play custom quests, you need to press whatever you assigned to A twice to bring up a dialog. Then select the .qst file there that you want to play. Alternatively, our very own Sephiroth has completed an excellent tutorial on the matter here.
Q: How do I play the first and second quests?
A. To play the second quest, type in "ZELDA" as the name. To play the third quest, type in "ALPHA" as the name.
Q: Is it possible to run 1.90 in Windows 2000 or XP?
A: If you are lucky, XP will include a very limited support for DOS games. Even if it does run, it may run slowly (I know AGSetup.exe is... though you'll only find that program in 1.90.). Chances are you will need a program like VDMSound (just search for it in Google). It may run ZC... it may not. If you are unlucky enough, you may have to forgo 1.90 completely. Unfortunately, with MS-DOS going gone the way of the dinosaur, true compatibility with 1.90 will only get rarer and rarer.
Q: I really want to play quest XXXX, but it's for 1.92. I should be able to play it in 2.10 because it's a newer version, right?
A: No, no, no! While the developers have done their best to keep backwards compatibility, some bugs will arise. It is highly, highly recommended to play with the suggested version to prevent game-stopping problems. Even quests made in 2.10 have been reported as unplayable in 2.10.2. The only acceptable exception to this rule is using The 184 Player to run quests made in 1.92b183.
How do I install multiple versions of Zelda Classic on my computer?
A: It's actually surprisingly simple. Simply give each version you would like a separate folder. As long as no two versions exist in the same directory, they should remain separate and both completely usable.
Q: Help! I've discovered a program-crippling bug! Will you help me, kind sirs?
A: As much as we'd like to, unfortunately we can't help you with problems in the program itself. We are not the developers, simply fans. However, if you do wish to report bugs, you can do so at Armaggedon Games, the official home of Zelda Classic.
Q: How do you make ZC or ZQ open in a window?
A: The simplest way is to use ZC Launcher, a useful program bundled with some releases of Zelda Classic. Without ZC Launcher, first make a shortcut for the application, then right click and go to Properties. Select the Shortcut tab. In the Target box at the end of the target name, add " -res 512 448 big -windowed" if it's for Zelda Classic, or add " -windowed -large -scale 1" if it's for ZQuest.
Q: I have WindowBlinds. How can I get ZC and ZQuest to run in Windowed Mode without crashing?
A: The answer is simple, yet ugly looking if you are spoiled with pretty visual styles. If you have XP, the fastest way is to go to the compatibility tab of a program and disable XP skinning. If you don't have XP, you can open up the WindowBlinds control panel and add ZC and ZQuest to the exclusion list (programs to not skin). As of WindowBlinds 4.4, support for ZC Windowed has magically appeared out of thin air.
Q: In versions 2.10 and above, what are quest keys and how do I use them?
Quest keys are small text files that allow you to open a quest without a password in ZQuest or activate all cheats of a quest by default in Zelda Classic (regardless of whether a cheat code has been entered). To generate this file when saving, go to Quest->Header and check "Save Key File." Never, ever give away your key file.

~Common Problems~
It's important to remember that Zelda Classic is only a computer program, and as such has bugs or inconsistencies by definition. Oftimes, however, these are either not entirely the fault of the program or simply a result of a lack of familiarity. Here are a few of the most common problems in the program and short guides on how to fix them.

~Sound Errors~
Whenever I try to play a quest, the music won't play, but sound effects do! What's going on here?
The answer is twofold- it depends on whether you are playing a Windows or Linux distribution of Zelda Classic. If you are using Windows, the problem is not in the program itself. There are three main things you can do to try to get the music playing again:
  1. Make sure your computer speakers are actually turned on.
  2. You can double-click the speaker icon in the lower right-hand corner of the taskbar to access the volume controls. Make sure that the SW Synth channel is turned up- Windows uses this to play MIDI files.
  3. Finally, if even that doesn't work, it could be a problem with Allegro, a file that Zelda Classic uses to perform most of its functions. You can jump-start Alegro's music files by accessing ZQuest and going to Etc. -> Lost Woods. The music should work fine after this.
If you are using Linux, the problem is actually a MIDI incompatibility in the default settings or something technical like that. icon_razz.gif Fortunately, there is a solution:
  1. Download a soundfont from the internet (Here is the Unison one- it's legal, but see the caveats below).
  2. Download the allegro utility pat2dat from your distribution's repos.
  3. Run pat2dat on Unison ('man pat2dat' at command line for instructions on this).
  4. Place the resulting patches.dat file in your Zelda Classic directory.
This found fix the problem- however, there are some caveats with the Unison soundfont, listed below:
  • MIDI's may bleed into each other.
  • Wrong instruments may be heard.
  • The "Reverse Cymbal" GM instrument will not be heard.
These problems are soundfont-dependent. Acquiring another soundfont may eliminate the problems.
In 2.10, I've noticed that there are errors in the MIDI files while playing. What's up?
This is a well-documented and well-known bug in 2.10. Unfortunately, it has no real fix other than upgrading to 2.10.2- even this, however, may introduce other bugs.

~Windows Vista~
Unfortunately, it seems like many (if not all) versions of Zelda Classic are unable to work in Windows Vista if simply run as-is. Sometimes it doesn't open, and sometimes the program has errors while running. There are two very simple fixes for this problem:
  1. Right-click the file and select "Run as Administrator."
  2. Use ZC Launcher to open Zelda Classic or ZQuest.
For some, this still does not work. Angeal, a member of our staff and Vista user, has provided this workaround that seems to work well.
Ok, well, I've been trying to get 2.10 to open on my Vista PC, but to no avail, I was not able to. I've been trying for over 6 months. So, I went on a hunt to find out how to get it to run. Well, I had stumbled onto something called Virtual PC 2007 from Microsoft to allow me to install another OS inside of Vista as a program you can run. (It totally kicks ass seeing XP boot up in a window) So, I did that, and the computer would still do the triple flash thing, and crashed... Total SUCKAGE. So, I found another program like that called Parallels Workstation 2.2, and once again, installed it, and install XP as a program. Once again, it did the triple flash deal, then crashed... So finally I've been going around searching forums all over the interweb, and came across one. I did what one guy had said to do in the quote.
QUOTE(John.Wilkinson @ forums.cnet.com)
-> Close the box that pops up, open (My) Computer, right-click the optical drive icon, choose Explore (not Open), browse for the installer, wherever it may be located on the disc, right-click it, choose the Compatibility tab, set it for Windows XP, OK your way out, and launch the installer. Note you'll also have to enable compatibility mode in C:\Program Files for the program once it's installed.

-> That's a never-ending argument with both camps having legitimate reasoning and evidence to back up their claims. In truth it's not that big of deal and I generally just use Sleep Mode to minimize power usage while reducing boot time the next morning.

-> The Cnet forums do not support post editing due to misuse, which is why you could not find the option.

Hope this helps,
CNet Forums Compatibility Topic.
So I right click the folder containing ZC and ZQ 2.10, and went "Explore" and right clicked both programs and set the compatibility to Windows XP SP2, and clicked the "Run as Admin" Checkbox. (Without the "Run as Admin," you can't load or save quests...) So, I went to load ZC, and the Admin approval thing came up, and I clicked "Approve," and it loaded ZC, and allowed me to load a quest, and play it. So, I played for about 10 minutes to check it out, and it runs like a charm. I then closed ZC, and tried ZQ, again coming up with the Admin Approval, and I clicked "Approve," thus opening ZQ in windowed mode, but went to "Etc" and down to Fullscreen. (You can leave it as windowed if that's your preference.) But I did a test quest, and it worked 100%. So if you Vista-goers have any problems before try this, and post your outcome here so I know if it's just luck on my part, or if it's a fix to all Vista users.Good luck. icon_wink.gif

(I also tried this with ZC/ZQ 1.92B183/184. Well, my outcome with that isn't exactly what I had wanted. It worked for ZC, but ZQ still doesn't want to load quests or save them. I kinda wished ZQ worked rather then ZC, because I am building my quest in Beta 183.)

~Windows 7~
Windows 7, on the other hand, is much more forgiving when in comes to both Zelda Classic and ZQuest. However, one known issue is that colors sometimes get messed up, necessitating reopening the program. Franpa has this fix:
Place this batch file (copy and paste into notepad and Save As insertnamehere.bat to make it a batch file) in your ZC folder and run. Change zelda-w.exe to zquest-w.exe to fix for ZQ.

@echo off
@echo ================================================
@echo Welcome to Franpa's Zelda Classic Colour Fix! v1.00
@echo ================================================
@echo Simply place this BAT file into your Zelda Classic folder and execute it instead of the games EXE file,
@echo this will close all instances of Explorer.exe then start the game, when closing
@echo the game, Explorer.exe is reloaded.

@echo off
taskkill /f /IM explorer.exe
Zelda-w.exe -fast
Start explorer.exe

For a less invasive fix, you can try this:

-Right-click "zelda-w.exe"
-Properties > Compatibility
[X] 256 colors
[X] 640x480 p screen resolution

~Frames Per Second~
When opening up older versions of Zelda Classic you may notice that the speed seems impossibly fast. This is simply an issue of the program displaying more frames per second (FPS) than is normal. You can easily fix this by pressing F1 on your keyboard to toggle VSync.

~2.10 BS-Style Animation~
BS-Style animation is an almost universally used feature of ZQuest that adds an extra frame of animation to Link and some enemies. Unfortunately, enabling this feature in 2.10 will have no effect on the quest. You can work around this by opening a file in 1.92, enabling BS-Style Animation, and then re-opening it in 2.10.

The original version of this guide was merely a compilation of other assistance topics, some of which are now outdated. Here are the threads that information was originally taken from. They may possibly still be of use to people.
Zelda Classic Downloads
Zelda Classic FAQ
Zelda Classic 2.10 Assistance Document
IMPORTANT: Zelda Classic Alphas & Betas
Having problems opening 2.10 ZC/ZQ, on Vista?
ZC in Ubuntu Hardy Heron 64-bit
ZC in Windows 7

Updated 04/20/2012 by Rambly with additional information about the 2.50 Release Candidates.
Updated 01/03/2013 by Nathaniel with new download information in response to the 2.50 official release, as well as the removal of outdated information about version 2.50.

Edited by Nathaniel, 03 February 2013 - 10:23 AM.

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users