Jump to content

Photo

ZQ Editor Size


  • Please log in to reply
6 replies to this topic

#1 Geoffrey

Geoffrey

    The Giraffe

  • Members
  • Gender:Unspecified

Posted 02 November 2019 - 12:56 PM

So, here's my problem. I'm using the new (2.5) interface at 1x scale, and the top and bottom of the program extend well beyond the edges of the screen (which has a resolution of 1366x768).

 

I feel like I'm taking crazy pills, because on my old Windows 7 laptop, whose screen had the same resolution, I did not have this problem: the new interface fit just fine.

 

I've tried full screen, but it crashes. I can use the classic interface at 2x scale, but it's a pain to use.

 

Any ideas?


  • Matthew likes this

#2 Lüt

Lüt

    Germanize

  • Members
  • Real Name:Steve
  • Gender:Male
  • Location:Chicago

Posted 02 November 2019 - 01:18 PM

The ZQuest window is 800x600, and the only option it has is to run in multiples of 100%, so 2x would put it at 1600x1200. If you have anything inbetween those two, something else is scaling it. The program is blurry in your screenshot, so it must be another Windows application or component. No idea what though.

#3 ShadowTiger

ShadowTiger

    !~~ah~~ha~~!

  • Members
  • Gender:Unspecified

Posted 02 November 2019 - 01:26 PM

Heh... I have a similar issue.  I have two monitors, both on 1920x1080 resolution.  In 1x mode, ZQuest is pretty darn small and I have to lean forward and squint to see it.  At 2x scale, I can have it docked at the very bottom of the screen and the entire menu system up top goes well into my upper monitor.  I'm sorry there isn't anything in between.



#4 Saffith

Saffith

    IPv7 user

  • ZC Developers
  • Gender:Male

Posted 02 November 2019 - 01:33 PM

Looks like it's scaled up by 25% - that'll be the system's high DPI setting. In Windows Settings -> System -> Display, it's the first setting under "Scale and Layout." Setting that to 100% should fix it.

However, that will make everything smaller. If you only want to change ZQuest, right-click zquest.exe or zquest-w.exe and go to Properties -> Compatibility -> Change high DPI settings, check the "Override high DPI scaling behavior" box, and set "Scaling performed by:" to "Application".

#5 Geoffrey

Geoffrey

    The Giraffe

  • Members
  • Gender:Unspecified

Posted 02 November 2019 - 01:36 PM

Thanks, Saffith! We did it, boys. :)



#6 Lüt

Lüt

    Germanize

  • Members
  • Real Name:Steve
  • Gender:Male
  • Location:Chicago

Posted 02 November 2019 - 01:44 PM

Now that it's mentioned, I noticed your browser was upscaling the images on the Firebird page also, so if you don't change that back, all your images are going to be distorted/blurred as well from the stretch.

BTW if you're going to use Firebird, Jared's done some updates to it this year, download the latest version from his sig (last post of his).

#7 Geoffrey

Geoffrey

    The Giraffe

  • Members
  • Gender:Unspecified

Posted 02 November 2019 - 01:48 PM

Now that it's mentioned, I noticed your browser was upscaling the images on the Firebird page also, so if you don't change that back, all your images are going to be distorted/blurred as well from the stretch.

BTW if you're going to use Firebird, Jared's done some updates to it this year, download the latest version from his sig (last post of his).

Thanks, Lut. I'm not sure what set I'll use, but I'm glad to have that updated file now.


  • Lüt likes this


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users